Partial service disruption

Incident Report for VPN

Resolved

This incident has been resolved
Posted Jul 02, 2025 - 08:19 UTC

Monitoring

We're having issues with our services provider and our infrastructure team managed to move core services to another one.
Posted Jul 01, 2025 - 21:02 UTC
This incident affected: Login, Login and payments, and Subscriptions.