Residential servers are unavailable when using Chrome

Incident Report for VPN

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 08:41 UTC

Identified

We are currently experiencing issues where residential servers are unavailable when using Chrome. Our team is working to resolve this as soon as possible. We recommend using apps for accessing residential servers.
Posted Jun 05, 2025 - 09:51 UTC
This incident affected: Networking configuration.